Title configure --prefix option is not respected
Type defect Module core build
Severity much work obstructed Platform N/A
Keywords Nosy List tbrowder
These controls should only be changed by committers and tracker administrators.
Status new   Reason
Priority normal   Assigned To

Created on 2016-04-13.17:01:09 by tbrowder, last changed 2016-04-13.17:23:45 by tbrowder.

msg2565 [hidden] ([hidden]) Date: 2016-04-13.17:23:44
Update: Okay, nothing is overwritten (whew!), but /usr/local/opt still 
wasn't used and /usr/local/bin/xemacs is a soft link to the executable 
name 'xemacs-21.5-b34'.  How is configure supposed to work--it's not 
doing what --help says? For now I created aliases to point to the 
desired xemacs and I'm back to normal (except for my ~/.xemacs dir which 
isn't liked by xemacs beta).
msg2564 [hidden] ([hidden]) Date: 2016-04-13.17:01:08
I tried to install xemacs beta alogside xemacs stable so I tried to 
configure it so:  ./configure --prefix=/usr/local/opt  but it installed 
in /usr/local and overwrote my xemacs stable: AARGH!!  The generated 
configure.log has the correct prefix but the generated Makefile does NOT 
(discovered after the fact of the erroneous install).
Date User Action Args
2016-04-13 17:23:45tbrowdersetmessages: + msg2565
2016-04-13 17:01:09tbrowdercreate