Issue536

classification
Title deja vu font size setting does not affect some characters
Type defect Module core code 21.5
Severity inconvenience Platform x86, x86_64
Keywords redisplay Nosy List jonbaron1944, stephen
explanation
process
These controls should only be changed by committers and tracker administrators.
Status assigned   Reason
Superseder  
Priority normal   Assigned To

Created on 2009-07-01.00:34:50 by jonbaron1944, last changed 2009-07-05.00:04:17 by jonbaron1944.

Files
File name Uploaded Type Edit Remove
typescript jonbaron1944, 2009-07-05.00:04:17 application/octet-stream
Messages
msg1264 [hidden] ([hidden]) Date: 2009-07-05.00:04:17
  Message-ID: <1246752257.59.0.423490313043.issue536@xemacs.org>
I built xemacs-21.5.29 from source with
--with-xft --with-mule
and the result does not obey my attempts to get a larger font than the
default.  The font specifcation was
XEmacs.default.attributeFont: -misc-dejavu sans
mono-medium-r-*-*-*-220-*-*-*-*-*-*
but the 220 seems to be completely ignored.  (I also tried iso10646...
and that didn't help.)
I'm attaching the messages that apeared on the screen.
msg1257 [hidden] ([hidden]) Date: 2009-07-01.16:52:34
  Message-ID: <1246467154.38.0.936990945588.issue536@xemacs.org>
I've reported this to Fedora, in view of Stephen's msg1256 (below):

https://bugzilla.redhat.com/show_bug.cgi?id=508383
msg1256 [hidden] ([hidden]) Date: 2009-07-01.16:01:04
  Message-ID: <1246464064.87.0.58022276313.issue536@xemacs.org>
Thanks for checking.  Emacs does these things quite a bit differently from XEmacs; 
I'm not surprised you got a different result there.

To get a verbose description of the main features of your XEmacs configuration, use 
M-x describe-installation.  For more detail about both the main configuration and 
the Lisp environment suitable for a bug report when it's not clear what information 
might be useful, M-x report-xemacs-bug.
For Xft support specifically, M-: (featurep 'xft-fonts) RET.

According to
http://rpmfind.net//linux/RPM/fedora/devel/x86_64/xemacs-21.5.29-1.fc12.x86_64.html
none of Xft, fontconfig, and freetype is a required library, so I would guess it's 
not configured in the Fedora RPMs.
msg1238 [hidden] ([hidden]) Date: 2009-07-01.10:12:29
  Message-ID: <1246443149.4.0.202696395492.issue536@xemacs.org>
I don't know how to tell if xemacs is xft enabled.  It is version
21.5.8, using the Fedora 11 RPM, but this has been a problem through
several previous versions.

When I did C-x = in xemacs on the apostrophe in my example, I got:
(U+2019 greek-iso8859-7 34).  The eta was also greek.  The quotation
marks were chinese-gb2312.  The same tests in emacs did not say anything
about another font.  For example, the apostrophe was
(324393, #o1234571, #x53979, file...).

I tried both suggestions and they did not fix the problem.  Putting
something in init.el gives the right size font except for the problem
characters, but then the geometry setting in .Xresources uses the
smaller font to set the window. The XEmacs.default.attrributeFontSet did
not seem to get processed at all, and everything was small.
msg1232 [hidden] ([hidden]) Date: 2009-07-01.08:11:08
  Message-ID: <1246435868.72.0.0847727185061.issue536@xemacs.org>
I imagine the problem is that in fact the specified font is not used for 
those characters because they are not in the same Emacs charset.  You 
can check this with C-x = with point just before a character whose 
charset you wish to check (usually displayed as a block cursor covering 
the character).

If you're not using an XFT-enabled XEmacs, I'm not sure what can be done 
about it, as XEmacs is dependent on X to return an appropriate font for 
each charset (XEmacs charsets correspond exactly to the standard font 
repertoires for legacy X11 fonts).  You could try specifying

XEmacs.default.attributeFontSet: -misc-dejavu sans mono-medium-
r-*-*-*-220-*-*-*-*-iso10646-1,-misc-dejavu sans mono-medium-
r-*-*-*-220-*-*-*-*-*-*

Or do

(set-face-font 'default "-misc-dejavu sans mono-medium-
r-*-*-*-220-*-*-*-*-iso10646-1" nil nil 'prepend)

in init.el.

If you are using Xft, currently the font selection algorithm simply 
emulates the legacy X11 approach.  I plan to work on this in the next 
weeks but don't know when results will make it into the distribution.
msg1231 [hidden] ([hidden]) Date: 2009-07-01.00:34:50
in .Xresources I have

XEmacs.default.attributeFont: -misc-dejavu sans mono-medium-
r-*-*-*-220-*-*-*-*-*-*

This has worked for many years, but some new characters are not affected
by the "220" setting ans show up as if the setting were (I think) 100,
that is, about half as high as they should be.  The following line is an
example:

practitioners’  η2 = .35 “all must have prizes.”

Note the apostrophe, the quotes, and the eta.  These all display as tiny
characters.

The problem does not occur in Gnome Terminal or in Emacs, so I don't
think it is in the font itself or in X.

This problem has been present for a while (at least three versions), but
it is becoming more bothersome as more people send text files with these
characters.
History
Date User Action Args
2009-07-05 00:04:17jonbaron1944setfiles: + typescript
messages: + msg1264
2009-07-01 16:52:34jonbaron1944setmessages: + msg1257
2009-07-01 16:01:04stephensetmessages: + msg1256
2009-07-01 10:12:29jonbaron1944setmessages: + msg1238
2009-07-01 08:11:08stephensetstatus: new -> assigned
assignedto: stephen
messages: + msg1232
nosy: + stephen
2009-07-01 00:34:50jonbaron1944create